Why am I unable to see a lookup field that is newly added in Salesforce?

Why am I unable to see a lookup field that is newly added in Salesforce?

Scenario:
The Salesforce Admin created some new fields in an object, but a lookup field is still not showing in the Salesforce Source or Destination component.
Solution:
It may be that your Salesforce Admin created the field but did not properly set field-level security.

Your Salesforce administrator should make that field accessible for reading and edit and then the field should show up for you. Please contact your Salesforce administrator about the issue.

See the following supporting documentation links:


    • Related Articles

    • Match multiple columns with Lookup Plus

      You can match multiple columns using the Lookup Plus component. See the steps below for one possible solution: Create a new data flow. This data flow will build a lookup reference dictionary and store it in a package variable. Insert a data flow ...
    • Error Message: Invalid Server Host (Salesforce Connection)

      Action: When using the Salesforce Connection I am getting the error message below: Error Message: "Invalid Server Host" Solution: Salesforce has sent out notices to their customers that some Salesforce Platform API legacy versions will be deprecated ...
    • Where can I find the documentation for the Salesforce Source?

      You can find documentation related to all the COZYROC SSIS+ Component Suite components from the main products page.  Specific documentation for the Salesforce Source can be found at the following link.  For many of the components you can find ...
    • Where can I find the documentation for the Salesforce Destination?

      You can find documentation related to all the COZYROC SSIS+ Component Suite components from the main products page.  Specific documentation for the Salesforce Destination can be found at the following link.  For many of the components you can find ...
    • Missing objects or columns when using Salesforce Destination Component

      Most likely the reason for object or column to be missing is that you are using older version of Salesforce API. To verify which version of Salesforce API you are using please check what is showing in the Server URL field on the Salesforce Connection ...